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Windows KMS服務狀態異常如何解決?

本文主要介紹Windows KMS服務狀態異常的可能原因及其解決方法。

問題現象

當用戶在使用ECS實例時,實例與KMS Server之間的連接出現異常。現象

可能原因

  • 用戶自定義DNS配置時,未保留至少一個阿里云內網DNS,導致無法成功接入阿里云內網。

  • KMS Server地址配置錯誤,導致實例無法與KMS Server服務建立連接。

  • 本地網絡異常,無法連接KMS Server服務。

解決方案

重要
  • 如果您對實例或數據有修改、變更等風險操作,務必注意實例的容災、容錯能力,確保數據安全。

  • 如果您對實例(包括但不限于ECS、RDS)等進行配置與數據修改,建議提前創建快照或開啟RDS日志備份等功能。

  • 如果您在阿里云平臺授權或者提交過登錄賬號、密碼等安全信息,建議您及時修改。

方案一:檢查自定義DNS配置

  1. 使用Win+R組合鍵打開運行對話框。

  2. 運行窗口中輸入cmd,并單擊確認打開命令行窗口。

  3. 在命令行窗口輸入ipconfig/all命令,并按Enter鍵。

  4. 檢查自定義DNS配置是否至少保留一個阿里云內網DNS。DNS檢查

    說明

    若沒有保留至少一個阿里云內網DNS,請重新配置DNS。具體操作,請參見如何在Linux實例中自定義配置DNS。

方案二:重新配置KMS Server地址

  1. 使用Win+R組合鍵打開運行對話框。

  2. 運行窗口中輸入cmd,并單擊確認打開命令行窗口。

  3. 在命令行窗口依次輸入如下命令,并按Enter鍵。

    slmgr.vbs /ckms
    slmgr.vbs /skms kms.cloud.aliyuncs.com
    slmgr.vbs /ato

    1

方案三:檢查本地網絡連接是否正常

  1. 使用Win+R組合鍵打開運行對話框。

  2. 運行窗口中輸入cmd,并單擊確認打開命令行窗口。

  3. 在命令行窗口輸入ping 100.10X.X.XX命令,并按Enter鍵測試網絡連接是否正常。PING

    說明
    • 若如上圖所示,則網絡連接正常。

    • 若丟包率為100%則表示無法連接網絡,請檢查本地網絡配置。