本文為您介紹如何解決在備份OSS時遇到的問題。
OSS備份失敗,提示“訪問OSS Bucket失敗,OSS Bucket的訪問策略限制訪問”
問題現象
oss備份失敗,提示“訪問OSS Bucket失敗,OSS Bucket的訪問策略限制訪問,請檢查OSS Bucket訪問策略和VPC配置確保云備份擁有訪問待備份OSS Bucket的權限”。
問題原因
由于OSS Bucket的訪問策略設置了限制,導致云備份服務沒有權限訪問待備份的OSS Bucket。
解決方法
登錄OSS控制臺。
找到對應的OSS Bucket,在Bucket 授權策略頁簽,單擊新增授權。
授權用戶:根據需要選擇所有賬號,子賬號或其他賬號進行授權。更多信息,請參見通過Bucket Policy授權訪問OSS。
授權操作:選擇高級設置。
效力:選擇允許。
操作:為云備份訪問OSS Bucket需要獲取的權限。您可根據如下列表,對操作選擇相同的權限。更多信息,請參見服務關聯角色。
[ "oss:ListObjects", "oss:GetBucketAcl", "oss:GetBucketLocation", "oss:GetBucketInfo", "oss:PutObject", "oss:GetObject", "oss:PutObjectACL", "oss:GetObjectACL", "oss:PutObjectTagging", "oss:GetObjectTagging", "oss:AbortMultipartUpload", "oss:ListMultipartUploads", "oss:ListParts" ]
條件:勾選訪問方式,選擇HTTP。IP設置為192.168.0.0/16。
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