本文介紹在云盤異步復制過程中,遇到啟動復制或啟動容災演練時提示ECS引導鏡像失敗時,如何進行修復。如果您曾手動修改過引導鏡像,并在容災演練或故障切換后遇到無法進入操作系統的問題,也可參考本文的解決方案。
問題現象
在嘗試開始數據復制或是預覽容災演練方案時,系統將會提示引導鏡像錯誤。如下圖所示:
原因分析
在啟動復制時,HDR首先會在容災站點上利用代理鏡像創建對應的容災ECS實例。隨后,它將從主站點復制數據到新創建的ECS上,并在復制周期結束后生成或更新恢復點。當執行容災演練時,HDR會基于代理鏡像在容災環境中創建一個用于演練的ECS,并采用最新的恢復點來替換其內容。
由于HDR不直接干預操作系統的內部運作,如果生產環境中的ECS鏡像因為升級、下線或刪除等原因變得不可用,HDR可能無法準確地識別ECS的啟動模式及操作系統版本信息。這可能導致在實際進行容災切換或是容災演練過程中,目標端的ECS無法正常啟動。有關啟動模式的最佳實踐,可參考ECS實例啟動模式最佳實踐。
解決方法
自動修復
在預覽時,如果系統提示鏡像存在問題,您可以通過單擊查看詳情來獲取更多信息。
在彈出的詳情對話框中,您可以為一臺或多臺ECS實例選擇合適的可用鏡像進行配置。HDR功能結合了云助手服務,提供了一鍵修復功能,您可通過單擊修復進行自動修復。該功能會自動運行腳本來檢測ECS實例的啟動模式、操作系統及其版本等關鍵信息,并據此智能匹配合適的可用引導鏡像。您可以在云助手控制臺中查看所有執行操作的具體細節。
手動修復
如果自動修復功能未能找到合適的鏡像,您可以登錄ECS系統確認啟動模式和操作系統版本。隨后,根據實際情況修改ECS引導鏡像,并繼續進行復制或容災演練。
文檔內容是否對您有幫助?