本文介紹如何快速解決使用端云互聯時,可能遇到的拒絕請求問題。
說明
Cloud Toolkit 2020.9.1及以上版本中,增加端云互聯一鍵診斷功能,可以提供診斷結果,幫助您排查etrans通道啟動異常、服務連接不通以及其它可能出現的問題。請您及時升級Cloud Toolkit。
問題描述
當您使用端云互聯時,注冊中心拒絕請求,并收到以下錯誤信息:
code:403,msg: access denied
問題原因
由于注冊中心通過時間戳保證服務注冊的安全性,如果本地的系統時間不準確會導致云端注冊中心拒絕請求。
解決方案
請校準系統時間并進行重試。
本地應用能否與云端組件互聯?
可以,請將Cloud Toolkit升級到2020.9.1及以上版本。升級完成后,本地應用內的所有請求均能通過跳板機轉發到云端的Spring Cloud Gateway、數據庫、Redis和消息等組件。
文檔內容是否對您有幫助?